Bug 101 - "deleted" IMAP flag makes restored items not visible
Summary: "deleted" IMAP flag makes restored items not visible
Status: RESOLVED FIXED
Alias: None
Product: ZeXtras
Classification: Unclassified
Component: ZxBackup (show other bugs)
Version: 1.8.11
Hardware: -- Linux
: Normal trivial
Assignee: ZeXtras Bugzilla Admin
QA Contact:
URL: http://forums.zextras.com/zxbackup/78...
Depends on:
Blocks:
 
Reported: 2013-11-28 16:10 CET by Cine
Modified: 2013-12-13 15:49 CET (History)
0 users

See Also:
Browser: ---
Zimlet Chat version: ---
Zimbra Version: ANY


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cine 2013-11-28 16:10:09 CET
Not really a Bug, but a behaviour deemed too strict. 
This will be changed in ZeXtras Suite 1.8.12.

Cause:
- "deleted" IMAP flag

Affects:
- Emails

Description:
When an item flagged with the "deleted" IMAP flag is restored, the flag itself is restored. While this is the correct behaviour, it is not paricularily easy to deal with this kind of items because of the default behaviour of the ZWC.

Effects:
- The item(s) won't be visible neither in the Zimbra Web Client nor by the zmmailbox command.
- As soon as an IMAP client purges the mailbox, the item(s) will be deleted.

Steps to reproduce:
- Mark an item as "deleted" using an IMAP client or add the "deleted" flag through `zmmailbox modifyItemFlags`. From now on, the item will be only visible through an IMAP client set to show deleted items.
- Wait or force the IMAP client to purge deleted items from the mailbox.
- Run an Undelete Restore
- The item will be restored, but it won't be visible in the ZWC or through zmmailbox. The item will be only visible through an IMAP client set to show deleted items.
Comment 1 Cine 2013-12-13 15:49:51 CET
Resolved as of ZeXtras Suite 1.8.12