Bug 114 - Bug in zxsuite shell
Summary: Bug in zxsuite shell
Status: RESOLVED FIXED
Alias: None
Product: ZeXtras
Classification: Unclassified
Component: ZxCore (show other bugs)
Version: 1.8.13
Hardware: -- Linux
: Normal normal
Assignee: ZeXtras Bugzilla Admin
QA Contact:
URL:
Depends on:
Blocks:
 
Reported: 2014-03-26 05:57 CET by NiKo
Modified: 2014-11-05 15:05 CET (History)
2 users (show)

See Also:
Browser: ---
Zimlet Chat version: ---
Zimbra Version: ANY


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description NiKo 2014-03-26 05:57:56 CET
Hello,

P.S. Zimbra 8.0.6 is not available as choice in BugZilla...

Since release 1.8.13, it seems zxsuite shell has changed. In my opinion, there is a mistake is the last if/else :

  if [ -z "${COLUMNS}" -a ! $TPUT_EXISTS -eq 0 ]; then
elif [ -z "${COLUMNS}" -a $TPUT_EXISTS -eq 0 ]; then
else
fi

It doesn't work if zxsuite is called without a terminal and looking at the code, it seems the if/elif conditions are wrong. It should be :

  if [ -z "${COLUMNS}" -a $TPUT_EXISTS -eq 0 ]; then
elif [ -z "${COLUMNS}" -a $TPUT_EXISTS -ne 0 ]; then
else
fi

(remove the "!" in the "if" and change the "-eq" into "-ne" in the "elif")

Doing this change, zxsuite works in all situations, with or without a terminal.

Best regards
Comment 1 NiKo 2014-04-26 18:13:14 CEST
Hello,

No news for this bug. I have to edit the script at each update...

Thanks
Comment 2 Cine 2014-05-05 15:23:47 CEST
Issue confirmed, resolution in progress, fix slotted for ZeXtras Suite 1.8.16
Comment 3 ZeXtras Bugzilla Admin 2014-11-05 15:05:43 CET
Fixed since ZeXtras Suite 1.8.16