Bug 131 - Activesync between Blackberry Z10 not working 100%
Summary: Activesync between Blackberry Z10 not working 100%
Status: RESOLVED FIXED
Alias: None
Product: ZeXtras
Classification: Unclassified
Component: ZxMobile (show other bugs)
Version: 1.8.17
Hardware: -- Ubuntu 12 - 64 bit
: Normal major
Assignee: ZeXtras Bugzilla Admin
QA Contact:
URL:
Depends on:
Blocks:
 
Reported: 2014-08-14 06:33 CEST by AM
Modified: 2014-10-24 14:30 CEST (History)
4 users (show)

See Also:
Browser: ---
Zimlet Chat version: ---
Zimbra Version: 8.0.7


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description AM 2014-08-14 06:33:09 CEST
Marking a task as 'completed' on my Blackberry Z10 (latest version of the OS) doesn't mark it completed on the server. The other way around works. Deleting or otherwise changing the task on the Blackberry go through to the server, only marking it as 'completed' doesn't have any effect.
Comment 1 AM 2014-08-14 06:35:08 CEST
I have tried the 'workaround' from bug #130, but that doesn't change anything. I also deleted and recreated the account on the Blackberry.
Comment 2 AM 2014-08-14 06:47:29 CEST
Addendum: changing the due-date on the BB also doesn't get through.....
Comment 3 AM 2014-08-14 07:32:47 CEST
If I create a task on the BB and mark it 'completed', it works. If it is an older task, this shows in the log if I mark it as complete on the Blackberry:

2014-08-14 09:30:35,681 INFO  [angelo@machils.org BB2B9E1DF0] [tid=736;] sync - ZxMobile Handler: [62.140.132.221] ZxMobile Command Sync on account angelo@machils.org from device BlackBerry/BB2B9E1DF0
2014-08-14 09:30:35,688 INFO  [angelo@machils.org BB2B9E1DF0] [tid=736;] sync - Sync[178]: Sending previous sync state: 0b1144a8f9a54259bead8921511df141/15/23/19
2014-08-14 09:30:35,796 INFO  [angelo@machils.org BB2B9E1DF0] [tid=736;] sync - Sync[178]: Device updated item 6973 on folder /Tasks
2014-08-14 09:30:35,895 WARN  [ZeXtras Activity Thread] [tid=64;] sync - Sync[177]: Unknown sync state: 0b1144a8f9a54259bead8921511df141/15/23/19
2014-08-14 09:30:36,054 INFO  [angelo@machils.org BB2B9E1DF0] [tid=736;] sync - Sync[177]: Connection broken on client: 0b1144a8-f9a5-4259-bead-8921511df141\BB2B9E1DF0
2014-08-14 09:30:36,078 INFO  [angelo@machils.org ApplDMPLKEH8FK10] [tid=741;] sync - ZxMobile Handler: [192.168.2.25] ZxMobile Command Sync on account angelo@machils.org from device iPad/ApplDMPLKEH8FK10
2014-08-14 09:30:36,116 INFO  [angelo@machils.org ApplDMPLKEH8FK10] [tid=741;] sync - Sync[179]: Changed 1 items: [6973] on folder /Tasks
2014-08-14 09:30:38,000 INFO  [angelo@machils.org ApplDMPLKEH8FK10] [tid=740;] sync - ZxMobile Handler: [192.168.2.25] ZxMobile Command Ping on account angelo@machils.org from device iPad/ApplDMPLKEH8FK10
2014-08-14 09:30:38,002 INFO  [angelo@machils.org ApplDMPLKEH8FK10] [tid=740;] sync - Ping[180]:  Class: Email - Folder: /Templates Class: Tasks - Folder: /Aanschaffen Class: Contacts - Folder: /Contacts Class: Email - Folder: /Later Class: Tasks - Folder: /Notes Class: Email - Folder: /Archives Class: Email - Folder: /Sent Class: Email - Folder: /Waiting Class: Email - Folder: /Junk Class: Email - Folder: /Trash Class: Calendar - Folder: /Calendar Class: Tasks - Folder: /Tasks Class: Email - Folder: /Inbox Class: Email - Folder: /To-Do
2014-08-14 09:30:39,517 INFO  [angelo@machils.org BB2B9E1DF0] [tid=736;] sync - ZxMobile Handler: [62.140.132.221] ZxMobile Command Sync on account angelo@machils.org from device BlackBerry/BB2B9E1DF0
2014-08-14 09:30:39,532 INFO  [angelo@machils.org BB2B9E1DF0] [tid=736;] sync - No changes were found
2014-08-14 09:30:40,606 INFO  [angelo@machils.org BB2B9E1DF0] [tid=740;] sync - ZxMobile Handler: [62.140.132.221] ZxMobile Command Sync on account angelo@machils.org from device BlackBerry/BB2B9E1DF0

So the sync is called, but the server/software doesn't see any change....
Comment 4 Zeus 2014-08-14 10:35:21 CEST
Hi AM,
I just perform some test on it.
Marking task as completed it's been show as completed on Zimbra but the percentage remain to zero and there is no green bar on task.
But, if you try to enter in to the task infos, you'll see the status as "completed"
Could you please confirm that to me?
Comment 5 AM 2014-08-14 11:09:52 CEST
This happens when the task is created on the Blackberry and then marked as 'completed'. In that case I can confirm your observations.

If however it is an existing task (perhaps created by another system, either mobile or webapp), there is no indication what-so-ever on the server and the task keeps as the status was before.....

Few tests:

* Tasks created through the webapp, marked completed through the Blackberry: Marking task as completed it's been show as completed on Zimbra but the percentage remain to zero and there is no green bar on task.
* Tasks created through the Blackberry and marked completed through the Blackberry: Marking task as completed it's been show as completed on Zimbra but the percentage remain to zero and there is no green bar on task.
* Task created through Thunderbird/Lightning and marked completed through the Blackberry: nothing changes for that task, the synclog shows that the sync is called, but it sees 'no changes', which of course is not true. The created task itself IS synced to the Blackberry however, just changes I make to it on the Blackberry aren't synced back properly.

I can test more later on with iOS and Android, but don't have any of these devices at hand at this moment.
Comment 6 AM 2014-08-14 11:11:35 CEST
Addendum to scenario #3: * Task created through Thunderbird/Lightning and marked completed through the Blackberry: nothing changes for that task, the synclog shows that the sync is called, but it sees 'no changes', which of course is not true. The created task itself IS synced to the Blackberry however, just changes I make to it on the Blackberry aren't synced back properly. -> if I delete the task on the Blackberry, this IS synced back to the server properly.
Comment 7 D0s0n 2014-08-14 13:42:54 CEST
We have scheduled for next release an improvement to set the progressbar to 100% when a task is  marked as complited.

However we need a debug log to understand the issue you have explained with Thunderbird/Lightning (caldav?), can you please report the information mentioned in section 3.7.1 of the "How to report a ZeXtras Suite issue" guide?
(http://wiki.zextras.com/wiki/How_to_report_a_ZeXtras_Suite_issue#Synchronization_Issues_for_a_device)
Comment 8 AM 2014-08-14 16:15:56 CEST
Hello,

I can also state that it is not only restricted to Thunderbird/Lightning (yes, CalDAV, what else???), but the same thing also happens with tasks created in Evolution (yes, also CalDAV).

I have created the logfile and send to community@zextras.com, but there is NO error in this log. I didn't expect it, since the synclog clearly states what is wrong, not really an error, but the software just doesn't see that something has changed in the task. In the mailbox.log there is also no error to be found.
Comment 9 AM 2014-08-14 16:26:25 CEST
Mobile device: Blackberry Z-10 (modelnumber STL100-2), OS 10.2.1.2977 using EAS14.x
Comment 10 AM 2014-08-14 16:52:48 CEST
The same thing happens on my iPad Air, iOS 7 (fully updated).
Comment 11 Cine 2014-10-24 14:30:57 CEST
Fixed in ZeXtras Suite 1.10.0