Bug 135 - Crash ZxChat after click the button "download" into message (Zimlet 1.21)
Summary: Crash ZxChat after click the button "download" into message (Zimlet 1.21)
Status: RESOLVED FIXED
Alias: None
Product: ZeXtras
Classification: Unclassified
Component: ZxChat (show other bugs)
Version: 1.9.2
Hardware: -- Ubuntu 12 - 64 bit
: Normal critical
Assignee: ZeXtras Bugzilla Admin
QA Contact:
URL:
Depends on:
Blocks:
 
Reported: 2014-09-24 18:24 CEST by aleksa106
Modified: 2014-11-05 14:56 CET (History)
1 user (show)

See Also:
Browser: ---
Zimlet Chat version: 1.21
Zimbra Version: 8.5.0


Attachments
Snapshot with crashed module (65.80 KB, image/png)
2014-09-24 18:25 CEST, aleksa106
Details

Note You need to log in before you can comment on or make changes to this bug.
Description aleksa106 2014-09-24 18:24:03 CEST
Crash ZxChat after click download button into post message.
Comment 1 aleksa106 2014-09-24 18:25:42 CEST
Created attachment 32 [details]
Snapshot with crashed module
Comment 2 D0s0n 2014-09-24 20:06:06 CEST
Why do you thinlk ZxChat is the cause for your issue?
If you disable the zxchat zimlet, doesn't your problem persist?

D0s0n
Comment 3 D0s0n 2014-09-25 15:46:37 CEST
Hi aleksa,

  sorry for my previous response, I misinterpreted the term "crash"...

I can confirm the issue: in some circumstances, a download of an attachment can invalidate a "ping" zxchat connection, and it cause a link-failure detection.

D0s0n
Comment 4 ZeXtras Bugzilla Admin 2014-11-05 14:56:24 CET
Added a workaround in ZeXtras Suite 1.22