Bug 139 - Chat window doesn't have close button
Summary: Chat window doesn't have close button
Status: RESOLVED INVALID
Alias: None
Product: ZeXtras
Classification: Unclassified
Component: ZxChat (show other bugs)
Version: 1.10.1
Hardware: Virtual Infrastructure - VMWare Ubuntu
: Normal normal
Assignee: ZeXtras Bugzilla Admin
QA Contact:
URL:
Depends on:
Blocks:
 
Reported: 2014-11-25 11:50 CET by Toni Garcia
Modified: 2014-11-26 22:57 CET (History)
0 users

See Also:
Browser: ---
Zimlet Chat version: 1.22
Zimbra Version: 8.5.0


Attachments
ZxChat window when no dev=1 added to URL (15.24 KB, image/png)
2014-11-25 16:22 CET, Toni Garcia
Details
ZxChat window when dev=1 added to URL (23.21 KB, image/png)
2014-11-25 16:22 CET, Toni Garcia
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toni Garcia 2014-11-25 11:50:58 CET
Since upgrade to zimlet version 1.22, chat windows don't show a close button and we can only hide/unhide them by clicking on the top bar.

It's a expected behaviour?

In this case, what's the right way to close a chat window?
Comment 1 ZeXtras Bugzilla Admin 2014-11-25 13:51:27 CET
Hello Toni,
thank you for filing this issue.

Could you please:

- Clear your server's cache running the "zmprov fc zimlet" command
- Clear your browser's cache
- Access the ZWC in "Dev Mode" by appending "?dev=1" to the URL - e.g. https://mail.yourdomain.com/?dev=1
- Take a screenshot of an affected window

Have a nice day,
Cine
the ZeXtras Team
Comment 2 Toni Garcia 2014-11-25 16:22:30 CET
Created attachment 33 [details]
ZxChat window when no dev=1 added to URL
Comment 3 Toni Garcia 2014-11-25 16:22:53 CET
Created attachment 34 [details]
ZxChat window when dev=1 added to URL
Comment 4 Toni Garcia 2014-11-25 16:24:29 CET
I realised that also no icons are shown.

Server cache was cleared after the upgrade, and i've tested clearing browser cache (on both Firefox and Chromium browsers)
Comment 5 ZeXtras Bugzilla Admin 2014-11-25 16:54:39 CET
Hello Toni,

this seems a cache issue, could you please disable the "Offline Client" feature if enabled, flush the server's cache again running `zmprov fc all`?  You can re-enable the offline feature after flushing the server's cache.

Have a nice day,
Cine
the ZeXtras Team
Comment 6 Toni Garcia 2014-11-25 17:10:03 CET
I don't use the "Offline client" feature.

Cleared again the server's cache without success.

I'll try to restart Zimbra tonight to see if it helps
Comment 7 Toni Garcia 2014-11-26 22:57:34 CET
Solved after restarting Zimbra