Bug 140 - Unable to view the Buddy List in Side Bar view. Buddy list is shown in Dock View. This was found after an upgrade from Zimbra 8.0.7 to 8.5.1 and ZeXtra Suite Update from 1.8.17 to 1.10.1.
Summary: Unable to view the Buddy List in Side Bar view. Buddy list is shown in Dock ...
Status: RESOLVED WORKSFORME
Alias: None
Product: ZeXtras
Classification: Unclassified
Component: ZxChat (show other bugs)
Version: 1.10.1
Hardware: Physical Infrastructure CentOS 6 - 64bit
: Normal normal
Assignee: ZeXtras Bugzilla Admin
QA Contact:
URL:
Depends on:
Blocks:
 
Reported: 2014-12-05 17:35 CET by echo501
Modified: 2014-12-15 13:35 CET (History)
0 users

See Also:
Browser: ---
Zimlet Chat version: 1.22
Zimbra Version: 8.5.1


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description echo501 2014-12-05 17:35:18 CET
steps to reproduce the issue

Look at zChat and change from Side Bar view to Dock View
-----------------------------------------------------------

your server's specs (cpu, ram, storage etc...)

HP Proliant ML350e G8, Quad Core Intell 1.8 GHZ, 3TB storage, 32GB RAM
-----------------------------------------------------------

your Zimbra version

Zimbra 8.5.1
-----------------------------------------------------------

your ZeXtras Suite/ZxMig version ( as the zimbra user run: "zxsuite/zxmig core getVersion" )

zextras_version                                     1.10.1
        zextras_commit                                      3441446ac7c333aeab45c74246f32a43ef022530
        zal_version                                         1.5.1
        zal_commit                                          3441446ac7c333aeab45c74246f32a43ef022530

zxmig: command not found
-----------------------------------------------------------

your OS, its version and architecture

Linux {hostname} 2.6.32-504.1.3.el6.x86_64 #1 SMP Tue Nov 11 17:57:25 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
-----------------------------------------------------------
the number of servers in your Zimbra infrastructure

1
-----------------------------------------------------------
the number of mailbox server in your Zimbra infrastructure

Less than 100
-----------------------------------------------------------
for GUI related issues, the browser you were using when experiencing the issue and its version

Chrome 38.0.2125.111 m
Firefox 23.01
-----------------------------------------------------------
for ZxChat Zimlet issues, the ZxChat Zimlet version

1.22

-----------------------------------------------------------
(when reporting migration issues, please specify this data for both the source and destination server)

-----------------------------------------------------------

Creating zimlet com_zimbra_url
Creating zimlet com_zextras_chat
ZxChatRequest - 12:15:14.057
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope">
<soap:Header>
<context xmlns="urn:zimbra">
<userAgent name="ZimbraWebClient - GC38 (Win)" version="8.5.1_GA_3056"/>
<session id="1365"/>
<account by="name">
{Email Address}
</account>
<format type="js"/>
<csrfToken>
0_a3772b3b9c03850646b13ca0414f784d4ade2e62
</csrfToken>
</context>
</soap:Header>
<soap:Body>
<ZxChatRequest xmlns="urn:zimbraAccount">
<action>
register_session
</action>
<clientVersion>
1.22
</clientVersion>
</ZxChatRequest>
</soap:Body>
</soap:Envelope>
shell control event: dW = 1185, dH = 781
shell control event: dW = 1185, dH = 781
Creating zimlet com_zimbra_date
Creating zimlet com_zimbra_srchhighlighter
Creating zimlet com_zimbra_email
Creating zimlet com_zimbra_webex
Creating zimlet com_zimbra_attachmail
Creating zimlet com_zimbra_ymemoticons
Creating zimlet com_zimbra_phone
Creating zimlet com_zimbra_attachcontacts
Creating zimlet com_zimbra_voiceprefs
zimlet handler not defined (SecureEmail)
zimlet handler not defined (ZmArchiveZimlet)
zimlet handler not defined (com_zimbra_linkedinimage_HandlerObject)
ROUND TRIP TIME: 157
shell control event: dW = 1185, dH = 781
shell control event: dW = 1185, dH = 781
Comment 1 ZeXtras Bugzilla Admin 2014-12-13 10:50:20 CET
Greetings,

this issue is still being investigated, will report back as soon as possible.
Comment 2 ZeXtras Bugzilla Admin 2014-12-15 11:20:27 CET
Greetings,
could you please confirm that the issue still persists after clearing both the server's and client's cache (as discussed at http://forums.zextras.com/zxchat/1119-zchat-buddies-list-doesnt-display-side-bar-view.html)?
Comment 3 echo501 2014-12-15 13:32:08 CET
Hello,

The day I reported the bug ( and initiated the forum discussion), clearing the cache on the server and client didn't solve the issue.  However since then the issue has resolved and I now have a properly working side bar.  So it must have been a caching issue.   Thanks for the follow up.   Please close user error.

Thanks echo501
Comment 4 echo501 2014-12-15 13:32:40 CET
Hello,

The day I reported the bug ( and initiated the forum discussion), clearing the cache on the server and client didn't solve the issue.  However since then the issue has resolved and I now have a properly working side bar.  So it must have been a caching issue.   Thanks for the follow up.   Please close user error.

Thanks echo501
Comment 5 ZeXtras Bugzilla Admin 2014-12-15 13:35:12 CET
Marking as resolved due to positive reporter's feedback.