Bug 146 - UnableToRestoreZEItemError: Unable to restore ZEItem
Summary: UnableToRestoreZEItemError: Unable to restore ZEItem
Status: RESOLVED WORKSFORME
Alias: None
Product: ZeXtras
Classification: Unclassified
Component: ZxBackup (show other bugs)
Version: 1.10.2
Hardware: Physical Infrastructure Ubuntu 12 - 64 bit
: Normal normal
Assignee: ZeXtras Bugzilla Admin
QA Contact:
URL:
Depends on:
Blocks:
 
Reported: 2015-02-16 11:30 CET by joel.garrido
Modified: 2015-05-05 13:34 CEST (History)
1 user (show)

See Also:
Browser: ---
Zimlet Chat version: ---
Zimbra Version: ZCS 8.X


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description joel.garrido 2015-02-16 11:30:26 CET
Hello

when i try to import backup from Zimbra 7.2.3 to Zimbra 8.6 using ZxBackup some items are unrestored :

2015-02-16 11:21:47,952 WARN Unable to restore item 24577, account achataing@rondy.fr(a10a70db-5754-46f5-b682-9c0747036413):
com.zextras.lib.Error.UnableToRestoreZEItemError: Unable to restore ZEItem
        at com.zextras.backup.ZEBItem.restore ( ZEBItem.java:671 )
        at com.zextras.op.backup.ZEExternalRestoreOperation.restoreItemsFromExternal ( ZEExternalRestoreOperation.java:987 )
        at com.zextras.op.backup.ZEExternalRestoreOperation.doOperation ( ZEExternalRestoreOperation.java:796 )
        at com.zextras.op.ZEOperation.exec ( ZEOperation.java:726 )
        at com.zextras.op.LegacyOperationProxy.exec ( LegacyOperationProxy.java:81 )
        at com.zextras.op.StatefulOperationImpl.exec ( StatefulOperationImpl.java:69 )
        at com.zextras.op.OperationStarterActivity.doActivity ( OperationStarterActivity.java:45 )
        at com.zextras.lib.activities.ActivityThread.run ( ActivityThread.java:118 )
Caused by: java.io.FileNotFoundException: /opt/zimbra/export3/items/j,/j,5OYTvsY8M0SM++F86z083ZuAE= (No such file or directory)
        at java.io.FileInputStream.open ( FileInputStream.java:-2 ) [native]
        at java.io.FileInputStream.<init> ( FileInputStream.java:138 )
        at com.zimbra.common.util.FileUtil.isGzipped ( FileUtil.java:149 )
        at org.openzal.zal.Utils.isGzipped ( Utils.java:237 )
        at com.zextras.lib.ZEBlobDigest.calculate ( ZEBlobDigest.java:34 )
        at com.zextras.backup.ZEBItem.restore ( ZEBItem.java:654 )
        at com.zextras.op.backup.ZEExternalRestoreOperation.restoreItemsFromExternal ( ZEExternalRestoreOperation.java:987 )
        at com.zextras.op.backup.ZEExternalRestoreOperation.doOperation ( ZEExternalRestoreOperation.java:796 )
        at com.zextras.op.ZEOperation.exec ( ZEOperation.java:726 )
        at com.zextras.op.LegacyOperationProxy.exec ( LegacyOperationProxy.java:81 )
        at com.zextras.op.StatefulOperationImpl.exec ( StatefulOperationImpl.java:69 )
        at com.zextras.op.OperationStarterActivity.doActivity ( OperationStarterActivity.java:45 )
        at com.zextras.lib.activities.ActivityThread.run ( ActivityThread.java:118 )


 
Can you help us understand what happen ?

Thanks for your help
Comment 1 Cine 2015-02-16 12:03:03 CET
Hello Joel!

Within the stacktrace you reported, a line caught my attention:

Caused by: java.io.FileNotFoundException: /opt/zimbra/export3/items/j,/j,5OYTvsY8M0SM++F86z083ZuAE= (No such file or directory)

This can be caused by either:
- A permission issue.
- An export error.
- An issue during the moving of the export path.
- A device issue or temporary unavailability.

Could you please check whether the file mentioned in the error exists or not and if it's correctly readable by the 'zimbra' user?
Comment 2 joel.garrido 2015-02-16 13:33:31 CET
Thank you for your reply

The file "/opt/zimbra/export3/items/j,/j,5OYTvsY8M0SM++F86z083ZuAE=" doesn't exist that explain the "no such file or directory" error.

What is interesting is when we try a second time to import the same Domain from the same export path we get less unrestored items and if we import a third time we have 0 unrestored items.
Why we have to do three times the operation ?and like this it is not possible to migrate quickly.
Comment 3 Cine 2015-02-16 13:45:38 CET
Hello Joel,

are you running an Export/Import migration or an Incremental Migration?

Have a nice day,
Cine
the ZeXtras Team
Comment 4 joel.garrido 2015-02-16 13:58:45 CET
I have run an export/import migration.

For the export i have installed ZxMig on he source server and for the import i have used ZxBackup from the ZxSuite on the destination server.

For the import and the export i used the GUI instead of the cli commands.

For the export storage i have tried nfs share and also local storage on source server but we obtain the same result.
Comment 5 Cine 2015-02-16 14:04:55 CET
Hello Joel,

I'm afraid that the cause of the issue could be the NFS share: could you please check the Export logs and report any error found there? 

Have a nice day,
Cine
Comment 6 joel.garrido 2015-02-16 14:15:24 CET
I don't think NFS share is the cause because i have tried to export localy on the source server and copy the result with rsync to the destiantion server and i have the same error.
Comment 7 joel.garrido 2015-02-16 15:27:14 CET
I have checked the export log and there is no error.

Do you have another idea ?

Thank you for your help
Comment 8 Cine 2015-02-16 15:45:11 CET
Hello Joel,
other possible causes are:

- A permission issue (make sure that the affected files are readable by the 'zimbra' user).
- An issue during the rsync to the destination server. 
- An issue in the destination server's storage device.

Does the file exist on the source server's export path? If so, what's the output of the 'stat' command for the file?
Comment 9 Cine 2015-05-05 13:34:55 CEST
Marking as "RESOLVED - WORKSFORME"