Bug 156 - Sync problem with HTC desire 601
Summary: Sync problem with HTC desire 601
Status: RESOLVED FIXED
Alias: None
Product: ZeXtras
Classification: Unclassified
Component: ZxMobile (show other bugs)
Version: 2.0.3
Hardware: Virtual Infrastructure - VMWare Linux
: Normal normal
Assignee: ZeXtras Bugzilla Admin
QA Contact:
URL:
Depends on:
Blocks:
 
Reported: 2015-08-10 09:53 CEST by service.informatique@saint-andre.re
Modified: 2016-05-11 08:20 CEST (History)
3 users (show)

See Also:
Browser: ---
Zimlet Chat version: ---
Zimbra Version: 8.6.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description service.informatique@saint-andre.re 2015-08-10 09:53:55 CEST
Hi,

We have some HTC desire 601 smartphones. We wanted to sync using active sync protocol.

First, the configuration of the smartphone failed - we have to delete the device on the admin zxmobile interface - and complete the configuration of the smartphone.

Second, the device is not sync - no mail, no contact, no calendar.

Here the logger


2015-08-10 13:50:57,842 [ZxMobile] debug Raw mobile request:
AwFqAAASRVZIVwNIVENEZXNpcmU2MDEAAVoDQW5kcm9pZCA0LjIuMgABWQNIVEMgRGVzaXJlIDYwMQAB
WAMqKioqKioqKioqKioxMzMzAAFcA05vdCBBdmFpbGFibGUAAQEBAQ==

2015-08-10 13:50:57,842 [ZxMobile] debug Mobile request:
<n1:Settings xmlns:n1="Settings">
  <n1:DeviceInformation>
    <n1:Set>
      <n1:Model>HTCDesire601</n1:Model>
      <n1:OS>Android 4.2.2</n1:OS>
      <n1:FriendlyName>HTC Desire 601</n1:FriendlyName>
      <n1:IMEI>************1333</n1:IMEI>
      <n1:PhoneNumber>Not Available</n1:PhoneNumber>
    </n1:Set>
  </n1:DeviceInformation>
</n1:Settings>

2015-08-10 13:50:57,864 [ZxMobile] debug Encoder: LoggerEncoder {
  SettingsEncoder120
}
2015-08-10 13:50:57,864 [ZxMobile] debug Actions:
StartEndWrapperAction { SettingsAction }
2015-08-10 13:50:57,864 [ZxMobile] debug Event: StartEvent
2015-08-10 13:50:57,866 [ZxMobile] debug Event: SettingsDeviceInformationEvent
2015-08-10 13:50:57,866 [ZxMobile] debug Event: EndEvent
2015-08-10 13:50:57,866 [ZxMobile] debug Raw mobile response:
AwFqAAASRUYDMQABAQ==

2015-08-10 13:50:57,866 [ZxMobile] debug Tags are valid
2015-08-10 13:50:57,866 [ZxMobile] debug Mobile response:
<n1:Settings xmlns:n1="Settings">
  <n1:Status>1</n1:Status>
</n1:Settings>
2015-08-10 13:50:57,909 [ZxMobile] debug XML Validation valid
2015-08-10 13:50:58,69 [ZxMobile] debug Raw mobile request:
AwFqAAAHVlIDMAABAQ==

2015-08-10 13:50:58,69 [ZxMobile] debug Mobile request:
<n1:FolderSync xmlns:n1="FolderHierarchy">
  <n1:SyncKey>0</n1:SyncKey>
</n1:FolderSync>
2015-08-10 13:50:58,72 [ZxMobile] debug Encoder: LoggerEncoder {
  FolderSyncEncoder
}
2015-08-10 13:50:58,72 [ZxMobile] debug Actions:
StartEndWrapperAction { ActionContainer {
  CollectionsSyncedEvent
} }
2015-08-10 13:50:58,72 [ZxMobile] debug Event: StartEvent
2015-08-10 13:50:58,73 [ZxMobile] debug Event: CollectionsSyncedEvent
2015-08-10 13:50:58,73 [ZxMobile] debug Event: EndEvent
2015-08-10 13:50:58,73 [ZxMobile] debug Raw mobile response:
AwFqAAAHVkwDMTQ0AAEB

2015-08-10 13:50:58,73 [ZxMobile] debug Tags are valid
2015-08-10 13:50:58,73 [ZxMobile] debug Mobile response:
<n1:FolderSync xmlns:n1="FolderHierarchy">
  <n1:Status>144</n1:Status>
</n1:FolderSync>
2015-08-10 13:50:58,80 [ZxMobile] debug XML Validation valid
2015-08-10 13:50:58,483 [ZxMobile] debug Raw mobile request:
AwFqAAAORUZHSANNUy1FQVMtUHJvdmlzaW9uaW5nLVdCWE1MAAEBAQE=

2015-08-10 13:50:58,484 [ZxMobile] debug Mobile request:
<n1:Provision xmlns:n1="Provision">
  <n1:Policies>
    <n1:Policy>
      <n1:PolicyType>MS-EAS-Provisioning-WBXML</n1:PolicyType>
    </n1:Policy>
  </n1:Policies>
</n1:Provision>
2015-08-10 13:50:58,489 [ZxMobile] debug Encoder: LoggerEncoder {
  ProvisionEncoder
}
2015-08-10 13:50:58,496 [ZxMobile] debug Actions:
StartEndWrapperAction { ActionContainer {
  ProvisionStatusResponseEvent
} }

2015-08-10 13:50:58,496 [ZxMobile] debug Event: StartEvent
2015-08-10 13:50:58,496 [ZxMobile] debug Event: ProvisionStatusResponseEvent
2015-08-10 13:50:58,497 [ZxMobile] debug Event: EndEvent
2015-08-10 13:50:58,497 [ZxMobile] debug Raw mobile response:
AwFqAAAORUsDMQABRkdIA01TLUVBUy1Qcm92aXNpb25pbmctV0JYTUwAAUsDMgABAQEB

2015-08-10 13:50:58,497 [ZxMobile] debug Tags are valid
2015-08-10 13:50:58,497 [ZxMobile] debug Mobile response:
<n1:Provision xmlns:n1="Provision">
  <n1:Status>1</n1:Status>
  <n1:Policies>
    <n1:Policy>
      <n1:PolicyType>MS-EAS-Provisioning-WBXML</n1:PolicyType>
      <n1:Status>2</n1:Status>
    </n1:Policy>
  </n1:Policies>
</n1:Provision>
2015-08-10 13:50:58,537 [ZxMobile] debug XML Validation valid
Comment 1 service.informatique@saint-andre.re 2015-08-10 10:02:32 CEST
For more information :
zimbra 8.6
zextras 2.0.3

the problem is only for these devices (iphone is ok) and wahtever the user account.

Thanx for your help
Comment 2 Jay 2015-08-11 09:43:51 CEST
Seems like a device management issue, server ask the device to provision but the account doesn't have any policy set or the device was already provisioned.

Can you provide your account policy settings?
(zxsuite mobile getProvisioning account address@example.com)

As a workaround you can try disabling device management for that particular account.
Comment 3 Cine 2016-05-11 08:20:31 CEST
Fixed in ZeXtras Suite 2.2.4