Bug 158 - "Buddy Group" issues
Summary: "Buddy Group" issues
Status: RESOLVED FIXED
Alias: None
Product: ZeXtras
Classification: Unclassified
Component: ZxChat (show other bugs)
Version: 2.0.3
Hardware: Physical Infrastructure CentOS 6 - 64bit
: Normal major
Assignee: ZeXtras Bugzilla Admin
QA Contact:
URL:
Depends on:
Blocks:
 
Reported: 2015-09-10 02:53 CEST by zimben
Modified: 2015-11-16 13:12 CET (History)
2 users (show)

See Also:
Browser: ---
Zimlet Chat version: 1.30
Zimbra Version: 8.0.7


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zimben 2015-09-10 02:53:29 CEST
Versions installed:
zxsuite: 2.0.3
zxchat:1.32
zimbra version: Release 8.0.7_GA_6021.RHEL6_64_20140408123911 RHEL6_64 FOSS edition.

Browser used: ANY

Background: zxchat previous version was 1.20. Then updated to the latest zxsuite which includes the latest zxchat zimlet.

Issue:
User reported that he created the contact groups after logging out and closing the browser, when he logged-in again several issues came out:
1. there was no buddies list. It(contact groups and non grouped contacts) will only show up when you type a letter in the search box.
2. once the buddies and the contact groups are shown after you did #1, the contact groups do not expand to list the users. it just shows the 1/5 (eg.) or the online/offline count. its as if its just listed. Arrow will not go down and list the buddies in the group.
3. you wont be able to delete the contact group.
4. the search for the users in the contact group will not show up.
5. the users cannot be re-added into the buddies list (since technically its already added).

For those who did not create the contact groups, no issues.

If a user/s(in the contact group) chat's with you, you'll be able to chat. But if you initiate the chat(on a user thats in your contact group), you wont be able to, since the name wont list or show up even on search. 

Errors seen on debug:
===============================================
Error: Raven has not been configured.
m()Zimlets...3afea2a (line 5328)
_l = "error"
_h = "Error: Raven has not been configured."
H()Zimlets...3afea2a (line 5300)
E.isSetup()Zimlets...3afea2a (line 5051)
f()Zimlets...3afea2a (line 5544)
p = false
y = ZmAppCtxt { _trees={...}, accountList=ZmAccountList, inStartup=false, more...}
g = "https://e6d27a26a2a24466...@feedback.zextras.com/3"
O</_g.prototype.init()Zimlets...3afea2a (line 9868)
m</f.prototype.init()Zimlets...3afea2a (line 495)
ZmZimletContext.prototype._finished_loadIncludes() line 1...val (4) (line 987)
ZmZimletMgr.prototype._finished_loadIncludes() line 1...val (4) (line 1674)
l = ["com_zextras_chat", "com_zimbra_attachcontacts", "com_zimbra_phone", 7 more...]
c = null
AjxCallback.prototype.run()newmail....com.ph (line 855)
e()Startup...8125659 (line 3774)
h = null
AjxCallback.simpleClosure/<()newmail....com.ph (line 888)
	

console[_l](_h)
===============================================

Error on expanding the Contact group:
===============================================
9-8-2015 23:50:46,133 ERROR [window.onerror]
TypeError: tableNode is null
DwtTreeItem.prototype._initialize()DwtTree...8125659 (line 530)
BuddyTreeItem</BuddyTreeItem.prototype._initialize()com_zex...ntry=US (line 31708)
DwtTreeItem.prototype._realizeDeferredChildren()DwtTree...8125659 (line 815)
DwtTreeItem.prototype._expand()DwtTree...8125659 (line 797)
GroupTreeItem</GroupTreeItem.prototype._expand()com_zex...ntry=US (line 30915)
DwtTreeItem._nodeIconMouseDownHdlr()DwtTree...8125659 (line 763)
	

tableNode.style.tableLayout = "auto";

DwtTree...8125659 (line 530)
com_zex...ntry=US (line 5063)
TypeError: tableNode is null

===============================================
Comment 1 zimben 2015-09-10 07:48:11 CEST
Additional findings:
- more than 1 buddy on a group will trigger this issue. Will not manifest if only 1 buddy is in a group.
- removed all buddies via cli and added them back. This returned to original state. then removed the empty contact groups. 
- As of the moment, all users were informed not to create contact groups.
Comment 2 Cine 2015-09-11 07:43:35 CEST
Hello zimben!

The cause of the issue has been found and fixed, the fix has already been pushed to the production branch and will be included in version 1.33 of the ZeXtras Chat Zimlet.

A custom ZeXtras Chat Zimlet 1.32 has been built to include this fix as well: http://www.zextras.com/download/zxchat1.32fix/com_zextras_chat.zip
Comment 3 zimben 2015-09-11 13:38:46 CEST
WOW! that was a fast fix... thanks so much! will deploy the fix and revert in case there is/are issues(hope none). Thanks again.
Comment 4 zimben 2015-09-11 14:31:51 CEST
Seems its still persistent. I've updated the zxchat using the link you provided. After adding the second buddy in the group, logout-login, the issue still seen. 

=====================================================================
Error: Raven has not been configured.
m(_l="error", _h="Error: Raven has not been configured.")Zimlets...3afea2a (line 5329)
H()Zimlets...3afea2a (line 5301)
E.isSetup()Zimlets...3afea2a (line 5052)
m(f=true, g=ZmAppCtxt { _trees={...}, accountList=ZmAccountList, inStartup=false, more...}, p="https://e6d27a26a2a24466...@feedback.zextras.com/3")Zimlets...3afea2a (line 5544)
O</_g.prototype.init()Zimlets...3afea2a (line 9868)
m</f.prototype.init()Zimlets...3afea2a (line 495)
ZmZimletContext.prototype._finished_loadIncludes() line 1...val (4) (line 987)
ZmZimletMgr.prototype._finished_loadIncludes(l=["com_zextras_chat", "com_zimbra_attachcontacts", "com_zimbra_phone", 7 more...], c=null) line 1...val (4) (line 1674)
AjxCallback.prototype.run()newmail....com.ph (line 855)
e(h=null)Startup...8125659 (line 3774)
AjxCallback.simpleClosure/<()newmail....com.ph (line 888)
	

console[_l](_h)

Zimlets...3afea2a (line 5329)
11-8-2015 22:27:51,932 ERROR [GroupTreeItem.applyFilter]

=====================================================================
Errors below on debug upon clicking the drop down arrow for the group:
=====================================================================
TypeError: t is null
DwtTreeItem.prototype._initialize()Startup...8125659 (line 19146)
z</O.prototype._initialize()Zimlets...3afea2a (line 20087)
DwtTreeItem.prototype._realizeDeferredChildren()Startup...8125659 (line 19356)
DwtTreeItem.prototype._expand()Startup...8125659 (line 19339)
g</A.prototype._expand()Zimlets...3afea2a (line 19658)
g</A.prototype.applyFilter()Zimlets...3afea2a (line 19888)
g</A.prototype.applyFilter()Zimlets...3afea2a (line 19879)
g</x.prototype.applyFilter()Zimlets...3afea2a (line 19437)
D/</<()Zimlets...3afea2a (line 18631)
o</s.prototype.run()Zimlets...3afea2a (line 5502)
g</v.prototype._handleChange()Zimlets...3afea2a (line 20887)
v/</<()Zimlets...3afea2a (line 20851)
	

t.style.tableLayout="auto"

Startup...8125659 (line 19146)
Zimlets...3afea2a (line 3904)

11-8-2015 22:27:53,679 ERROR [window.onerror]
TypeError: t is null
DwtTreeItem.prototype._initialize()Startup...8125659 (line 19146)
z</O.prototype._initialize()Zimlets...3afea2a (line 20087)
DwtTreeItem.prototype._realizeDeferredChildren()Startup...8125659 (line 19356)
DwtTreeItem.prototype._expand()Startup...8125659 (line 19339)
g</A.prototype._expand()Zimlets...3afea2a (line 19658)
DwtTreeItem._nodeIconMouseDownHdlr()Startup...8125659 (line 19311)
	

t.style.tableLayout="auto"
=====================================================================

Startup...8125659 (line 19146)
Zimlets...3afea2a (line 3904)
TypeError: t is null
	

t.style.tableLayout="auto"
Comment 5 info 2015-11-16 08:20:23 CET
Looks like 1.33 is not released yet, but some of my users ran into this bug.

What is the ETA on 1.33? Or should I proceed and install the patched version from :
http://www.zextras.com/download/zxchat1.32fix/com_zextras_chat.zip

Or is there a better patched version?


Barry
Comment 6 Cine 2015-11-16 13:12:42 CET
Hey Barry! ZeXtras Chat 1.33 will be released in a matter of days, but installing the patched 1.32 won't do no harm (the updater is based on the version, so once 1.33 is released you'll get a notification and will be able to autodeploy it as usual).