Bug 170 - zxbackup - Invalid recipient zimbra: 504 5.5.2 <zimbra>: Recipient address rejected: need fully-qualified addres
Summary: zxbackup - Invalid recipient zimbra: 504 5.5.2 <zimbra>: Recipient address re...
Status: RESOLVED FIXED
Alias: None
Product: ZeXtras
Classification: Unclassified
Component: ZxBackup (show other bugs)
Version: 2.0.4
Hardware: Virtual Infrastructure - Other (specify in description) Other
: Normal normal
Assignee: ZeXtras Bugzilla Admin
QA Contact:
URL:
Depends on:
Blocks:
 
Reported: 2015-12-06 21:42 CET by David Sommerseth
Modified: 2015-12-12 19:43 CET (History)
1 user (show)

See Also:
Browser: ---
Zimlet Chat version: ---
Zimbra Version: 8.6.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Sommerseth 2015-12-06 21:42:13 CET
Fresh Zimbra 8.6p4 64bit on Scientific Linux 7.1 (x86_64), I notice a lot of failures in /opt/zimbra/log/mailbox.log around the time the backup is running.

-----------------------------------------------------------------------------
2015-12-06 04:01:02,291 WARN  [ZeXtras Activity Thread] [] smtp - Failed to send message
com.zimbra.cs.mailclient.smtp.InvalidRecipientException: RCPT failed: Invalid recipient zimbra: 504 5.5.2 <zimbra>: Recipient address rejected: need fully-qualified address
        at com.zimbra.cs.mailclient.smtp.SmtpConnection.rcpt(SmtpConnection.java:682)
        at com.zimbra.cs.mailclient.smtp.SmtpConnection.sendInternal(SmtpConnection.java:566)
        at com.zimbra.cs.mailclient.smtp.SmtpConnection.sendMessage(SmtpConnection.java:498)
        at com.zimbra.cs.mailclient.smtp.SmtpConnection.sendMessage(SmtpConnection.java:472)
        at com.zimbra.cs.mailclient.smtp.SmtpTransport.sendMessage(SmtpTransport.java:225)
        at com.zextras.lib.EmailTransport.sendMessage(EmailTransport.java:47)
        at com.zextras.notification.SendNotificationMail.sendEmail(SendNotificationMail.java:158)
        at com.zextras.notification.SendNotificationMail.doActivity(SendNotificationMail.java:64)
        at com.zextras.lib.activities.ActivityThread.run(ActivityThread.java:118)
2015-12-06 04:01:02,292 WARN  [ZeXtras Activity Thread] [] extensions - Exception: unable to send notification to zimbra: javax.mail.SendFailedException: MESSAGE_NOT_DELIVERED;
  nested exception is:
        com.zimbra.cs.mailclient.smtp.InvalidRecipientException: RCPT failed: Invalid recipient zimbra: 504 5.5.2 <zimbra>: Recipient address rejected: need fully-qualified address
        at com.zimbra.cs.mailclient.smtp.SmtpTransport.notify ( SmtpTransport.java:300 )
        at com.zimbra.cs.mailclient.smtp.SmtpTransport.sendMessage ( SmtpTransport.java:232 )
        at com.zextras.lib.EmailTransport.sendMessage ( EmailTransport.java:47 )
        at com.zextras.notification.SendNotificationMail.sendEmail ( SendNotificationMail.java:158 )
        at com.zextras.notification.SendNotificationMail.doActivity ( SendNotificationMail.java:64 )
        at com.zextras.lib.activities.ActivityThread.run ( ActivityThread.java:118 )
Caused by: com.zimbra.cs.mailclient.smtp.InvalidRecipientException: RCPT failed: Invalid recipient zimbra: 504 5.5.2 <zimbra>: Recipient address rejected: need fully-qualified address
        at com.zimbra.cs.mailclient.smtp.SmtpConnection.rcpt ( SmtpConnection.java:682 )
        at com.zimbra.cs.mailclient.smtp.SmtpConnection.sendInternal ( SmtpConnection.java:566 )
        at com.zimbra.cs.mailclient.smtp.SmtpConnection.sendMessage ( SmtpConnection.java:498 )
        at com.zimbra.cs.mailclient.smtp.SmtpConnection.sendMessage ( SmtpConnection.java:472 )
        at com.zimbra.cs.mailclient.smtp.SmtpTransport.sendMessage ( SmtpTransport.java:225 )
        at com.zextras.lib.EmailTransport.sendMessage ( EmailTransport.java:47 )
        at com.zextras.notification.SendNotificationMail.sendEmail ( SendNotificationMail.java:158 )
        at com.zextras.notification.SendNotificationMail.doActivity ( SendNotificationMail.java:64 )
        at com.zextras.lib.activities.ActivityThread.run ( ActivityThread.java:118 )
-----------------------------------------------------------------------------
Comment 1 Jay 2015-12-07 08:28:31 CET
Fixed in ZeXtras 2.2.0, thank you for the report.
Comment 2 David Sommerseth 2015-12-12 19:43:20 CET
Is there a workaround which can be applied in the mean time?  I'm having several e-mails every day which is bounced back to the admin account due to this error.  I presume you don't want to announce an ETA for the 2.2 release?