Bug 174 - bug with iso-8859-1 encoded messages
Summary: bug with iso-8859-1 encoded messages
Status: RESOLVED FIXED
Alias: None
Product: ZeXtras
Classification: Unclassified
Component: ZxMobile (show other bugs)
Version: 2.2.0
Hardware: Virtual Infrastructure - VMWare Ubuntu 12 - 64 bit
: Normal major
Assignee: ZeXtras Bugzilla Admin
QA Contact:
URL:
Depends on:
Blocks:
 
Reported: 2016-01-05 16:45 CET by NiKo
Modified: 2016-01-11 16:35 CET (History)
2 users (show)

See Also:
Browser: ---
Zimlet Chat version: ---
Zimbra Version: 8.6.0


Attachments
Screenshot Mail UTF-8 : OK (70.24 KB, image/png)
2016-01-05 16:45 CET, NiKo
Details
Screenshot Mail ISO-8859-1 : KO (69.32 KB, image/png)
2016-01-05 16:45 CET, NiKo
Details
Mail UTF-8 sample (669 bytes, text/plain)
2016-01-05 16:46 CET, NiKo
Details
Mail ISO-8859-1 sample (662 bytes, text/plain)
2016-01-05 16:46 CET, NiKo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NiKo 2016-01-05 16:45:13 CET
Created attachment 43 [details]
Screenshot Mail UTF-8 : OK

Hello,

It seems Bug #73 is back with release 2.2.0...

When a message received is UTF-8 encoded, no issue, but when encoded in ISO-8859-1, all 8-bit ascii chars are replaced by "?".

Issue occurs on both iPhones and Androids and only since release 2.2.0.

See attachements

Thanks
Nicolas
Comment 1 NiKo 2016-01-05 16:45:53 CET
Created attachment 44 [details]
Screenshot Mail ISO-8859-1 : KO
Comment 2 NiKo 2016-01-05 16:46:20 CET
Created attachment 45 [details]
Mail UTF-8 sample
Comment 3 NiKo 2016-01-05 16:46:44 CET
Created attachment 46 [details]
Mail ISO-8859-1 sample
Comment 4 Cine 2016-01-08 10:58:21 CET
Successfully reproduced, fix scheduled for ZeXtras Suite 2.2.1
Comment 5 Cine 2016-01-11 16:35:08 CET
Fixed in ZeXtras Suite 2.2.1