Bug 211 - Chat not displayed after manual installation
Summary: Chat not displayed after manual installation
Status: RESOLVED FIXED
Alias: None
Product: ZeXtras
Classification: Unclassified
Component: ZxChat (show other bugs)
Version: 2.4.2
Hardware: Virtual Infrastructure - VMWare Linux
: Normal normal
Assignee: ZeXtras Bugzilla Admin
QA Contact:
URL:
Depends on:
Blocks:
 
Reported: 2016-11-14 09:45 CET by Pedro Sempere
Modified: 2016-11-15 10:30 CET (History)
1 user (show)

See Also:
Browser: ---
Zimlet Chat version: 1.36
Zimbra Version: 8.6.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro Sempere 2016-11-14 09:45:15 CET
Always include the following informations in your report:

    A precise description of the issue
After having problems with Zxchat with specific error childdiv undefined,  we decided to reinstall zextras chat manually. 
Even if chat is enable in Zextras GUI, chat is not displayed. When you access the section ZxChat is complaining that chat is installed but not enabled. When you enter the ZxCore page, you see the notification that it is running and initiated.
We have tried to open page with ?dev=1 and it is the same result. No errors with firebug.


    steps to reproduce the issue
-Have error published in:
https://forums.zextras.com/zxchat/1144-issue-zimbra-8-6-start-_childdiv-undefined.html

Perform the chat zimlet manual installation following guide as shown 
https://wiki.zextras.com/wiki/ZxChat_Zimlet_Install_Guide#ZeXtras_Chat_Zimlet_Manual_installation



    your server's specs (cpu, ram, storage etc...)
	4 processors, 1 CPU, RAM 32Gb
Storage
Filesystem                    Size  Used Avail Use% Mounted on
/dev/mapper/zimbra-root       9,1G  5,8G  2,8G  68% /
udev                           16G  4,0K   16G   1% /dev
tmpfs                         3,2G  272K  3,2G   1% /run
none                          5,0M     0  5,0M   0% /run/lock
none                           16G     0   16G   0% /run/shm
/dev/mapper/zimbra-var        9,1G 1013M  7,6G  12% /var
/dev/mapper/zimbra-zimbra      27G   15G   12G  55% /opt/zimbra
/dev/sda1                     464M   90M  346M  21% /boot
/dev/mapper/zextras-zxbackup  194G  140G   55G  72% /opt/zimbra/backup/zextras
/dev/mapper/correo-store      292G  196G   96G  68% /opt/zimbra/store


    your Zimbra version
8.6.0_GA_1153.FOSS

    your ZeXtras Suite/ZxMig version ( as the zimbra user run: "zxsuite/zxmig core getVersion" )
zextras version 2.4.2

    your OS, its version and architecture: Ubuntu 12.04 LTS
    the number of servers in your Zimbra infrastructure: 1
    the number of mailbox server in your Zimbra infrastructure: 234
    for GUI related issues, the browser you were using when experiencing the issue and its version: 
	Chrome 54.0.2840.87 64 bit Win 10 64 bit
	Mozilla Firefox 45.4.0 CentOS 7.2 64 bit
    for ZxChat Zimlet issues, the ZxChat Zimlet version
	version 1.36
Comment 1 Pedro Sempere 2016-11-15 10:30:35 CET
Dear Team,

please marked as resolved.

When you have this problem, it is mandatory to perform as zimbra user:

zmcontrol restart.

Later you are able to enable the chat and then the problem is fixed.