Bug 24 - Email sync
Summary: Email sync
Status: RESOLVED FIXED
Alias: None
Product: ZeXtras
Classification: Unclassified
Component: ZxMobile (show other bugs)
Version: 1.1.3
Hardware: -- All
: Normal normal
Assignee: ZeXtras Bugzilla Admin
QA Contact:
URL:
Depends on:
Blocks:
 
Reported: 2011-12-28 19:22 CET by Silhavy Filip
Modified: 2011-12-29 21:20 CET (History)
0 users

See Also:
Browser: ---
Zimlet Chat version: ---
Zimbra Version: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Silhavy Filip 2011-12-28 19:22:21 CET
Zxmobile failed with email sync.
mailbox.log:
2011-12-28 19:16:43,439 ERROR [ZxMobile Handler Thread] [] extensions - ZxMobile Handler: Exception: java.lang.IllegalStateException: character 12 is not allowed in output
	at org.xmlpull.mxp1_serializer.MXSerializer.writeElementContent(MXSerializer.java:949)
	at org.xmlpull.mxp1_serializer.MXSerializer.text(MXSerializer.java:778)
	at com.zextras.mobile.SyncResponse$XmlNode.serialize(SyncResponse.java:279)
	at com.zextras.mobile.SyncResponse$XmlNode.serialize(SyncResponse.java:231)
	at com.zextras.mobile.SyncResponse$XmlNode.serialize(SyncResponse.java:231)
	at com.zextras.mobile.SyncResponse$XmlNode.serialize(SyncResponse.java:231)
	at com.zextras.mobile.SyncResponse$XmlNode.serialize(SyncResponse.java:231)
	at com.zextras.mobile.SyncResponse$XmlNode.serialize(SyncResponse.java:231)
	at com.zextras.mobile.SyncResponse$XmlNode.serialize(SyncResponse.java:231)
	at com.zextras.mobile.SyncResponse$XmlNode.serialize(SyncResponse.java:231)
	at com.zextras.mobile.SyncResponse$XmlNode.serialize(SyncResponse.java:204)
	at com.zextras.mobile.SyncResponse.getDebugAnswer(SyncResponse.java:419)
	at com.zextras.mobile.ZEMobileHandler.managePost(ZEMobileHandler.java:341)
	at com.zextras.mobile.ZEMobileHandler.run(ZEMobileHandler.java:388)
Comment 1 ZeXtras Bugzilla Admin 2011-12-28 22:46:23 CET
Hi Filip and thanx for your feedback.

This problem is confirmed by our dev team and is caused by some binary character unprintable on debug log.

It will fix in next version (1.2.1) that will release very soon.

Meanwhile you can lower the log level to "information" to prevent this issue.