Bug 26 - Verify Zimbra's hostname and IP address during installation
Summary: Verify Zimbra's hostname and IP address during installation
Status: RESOLVED INVALID
Alias: None
Product: ZeXtras
Classification: Unclassified
Component: Installer (show other bugs)
Version: 1.2.1
Hardware: -- Debian
: Normal major
Assignee: ZeXtras Bugzilla Admin
QA Contact:
URL:
Depends on:
Blocks:
 
Reported: 2012-01-16 20:28 CET by Kosta Djordjevic
Modified: 2012-10-05 20:25 CEST (History)
2 users (show)

See Also:
Browser: ---
Zimlet Chat version: ---
Zimbra Version: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kosta Djordjevic 2012-01-16 20:28:14 CET
Installing ZeXtras zimlet on Zimbra server that is NOT binding to localhost fails with java network connection error.

Many users have customized their Zimbra to bind to a specific hostname/IP-address. This way we can use zimbra with apache side-by-side on the same port 80. This is only valid on the server with multiple IP addresses.

ZeXtras zimlet installation always assumes that the hostname is localhost. However in the above instance the zimbra server is running under different hostname/IP-address.

To replicate the problem and in this example I am using hostname.com as a zimbra's hostname:

1. Assign an available static IP address to the network interface (Debian 5):
iface eth0 inet static
address 192.168.10.10
netmask 255.255.255.255
up ip addr add 192.168.10.20/32 dev eth0
down ip addr del 192.168.10.20/32 dev eth0

2. Update DNS record for hostname.com:
@ A 192.168.10.20
mail A 192.168.10.20

3. Update hosts file
192.168.10.20 hostname.com
192.168.10.20 mail.hostname.com

4. Restart network interface

zmprov ms hostname.com zimbraMailPort 80
zmprov ms hostname.com zimbraMailSSLPort 443
zmprov ms hostname.com zimbraMtaAuthHost hostname.com

Open jetty.xml.in located in /opt/zimbra/jetty*****/etc folder

add a line <Set name="host">178.63.44.200</Set> so it gets like this:

<!-- user services connector, no SSL -->
<!-- HTTPBEGIN -->
<Call name="addConnector">
<Arg>
<New id="http" class="org.mortbay.jetty.nio.SelectChannelConnecto r">
<Set name="host">192.168.10.20</Set>
<Set name="port"><SystemProperty name="jetty.port" default="%%zimbraMailPort%%"/></Set>
<Set name="maxIdleTime">30000</Set>
<Set name="lowResourceMaxIdleTime">1000</Set>
<Set name="Acceptors">2</Set>
<Set name="confidentialPort">%%zimbraMailSSLPort%%</Set>
</New>
</Arg>
</Call>


Now in the zimbra.web.xml.in and zimbraAdim.web.xml.in located in /opt/zimbra/jetty*****/etc folder UNCOMMENT anb make this change:
<context-param>
<param-name>zimbra.soap.url</param-name>
<param-value>http://192.168.10.20/service/soap</param-value>
</context-param>


Restart zimbra

Try installing ZeXtras.

Error on ZeXtras zimlet install.



The temp fix:
Open hosts file and update it so that localhost points to above IP. Example:

192.168.10.20 localhost

Restart networking


Hopefully I have provided enough info to replicate the problem. I think this is an easy fix.
Comment 1 Cine 2012-01-17 09:49:50 CET
Hello Kosta.

I'm checking this bug right now, I'll post additional informations as soon as they are available.

Have a nice day,
Cine
Comment 2 Cine 2012-01-17 14:28:07 CET
Update on this bug:

I checked the situation, and seems that your problem is caused by a Zimbra configuration issue. The ZeXtras Installer uses the standard 'zmzimletctl' command to deploy the ZeXtras Zimlet, so the request is managed directly by Zimbra.

Can you please try to manually install a different Zimlet on the server and give me the outcome of the operation?

Have a nice day,
Cine