Bug 36 - Loosing data when abroad
Summary: Loosing data when abroad
Status: RESOLVED FIXED
Alias: None
Product: ZeXtras
Classification: Unclassified
Component: ZxMobile (show other bugs)
Version: 1.2.3
Hardware: -- Linux
: Normal normal
Assignee: ZeXtras Bugzilla Admin
QA Contact:
URL:
Depends on:
Blocks:
 
Reported: 2012-03-05 18:06 CET by Marc Bessière
Modified: 2012-10-05 20:24 CEST (History)
2 users (show)

See Also:
Browser: ---
Zimlet Chat version: ---
Zimbra Version: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Bessière 2012-03-05 18:06:30 CET
Zimbra   : ZCS OSE 7.1.4
OS       : Scientific Linux 5.7 (same as RHEL 5.7)

Phone    : Samsung Galaxy SII
OS       : Android 4.0.3
=================================================================================

When I was abroad without roaming because of data cost, I loose my contacts and appointments.

I was able to recover using the hotel wifi connection.
But in my room the signal was very weak.

As I understand the situation, the sync process has probably been disturbed by wifi connection loss during update.

Can you verify, that the sync process is well made in transactional manner as such data loss is very painful when abroad.

I'm back now, so I can't reproduce. But feel free to ask any questions.
Comment 1 Cine 2012-03-05 18:15:39 CET
Hello Marc,

thanks for the report.

A question: while abroad did you disable addressbook/calendar synchronization from the "Accounts and Sync" menu or the "Data Sync"/"Mobile Data" option from the Energy Saving menu/widget?


Regards,
Cine
Comment 2 Marc Bessière 2012-03-05 18:28:21 CET
(In reply to comment #1)
> A question: while abroad did you disable addressbook/calendar synchronization
> from the "Accounts and Sync" menu or the "Data Sync"/"Mobile Data" option from
> the Energy Saving menu/widget?

The answer is no. I have the roaming option unchecked by default, so I have nothing to do when crossing border to disable the mobile data.
Comment 3 Marc Bessière 2012-03-05 18:40:45 CET
Complementary information.

My zimbra server doesn't have a static IP. It's not a problem so far as the IP lease is often very long and I'm using ddclient to update dyndns frequently.

But I'm wondering what will happened if the IP is changed in the middle of a sync by example.
Comment 4 Marc Bessière 2012-03-05 19:10:59 CET
Dynamic IP is not the problem...

I just got a contact + mail resync from zero (probably calendar also). And during this period, the server IP was remaining stable.
Comment 5 Cine 2012-03-06 10:08:27 CET
Hello Marc.

ZeXtras Mobile uses the HTTP/S protocol to establish a connection between the mobile and the server and due to the request-response nature of this protocol if the stream is interrupted in the middle of a sync no changes are finalized and the next sync will start again from the last available syncstate.

This said, I see on a previous bug report you filed that you are using a nightly build of CM9 for Samsung Galaxy S2. While I am a great fan of CM myself, remember that you are using a nightly build of a Custom ROM which is still in Alpha stage, and this does not help when analyzing device-side problems...

I double checked the sync management with the devs just to be sure and I'll leave this bug open to allow other people with similar problems to post this report...



ps: while the dynamic IP was not the problem in this case, I've seen different devices (mainly HTC and Samsung) which only perform the DNS resolution for an Exchange Active Sync account during the first sync and keep this data cached until reboot, and in your case such behaviour will prevent you to synchronize your account after a new IP lease until you reboot the phone..  


Regards,
Cine
Comment 6 Marc Bessière 2012-03-06 15:17:49 CET
(In reply to comment #5)

> ZeXtras Mobile uses the HTTP/S protocol to establish a connection between the
> mobile and the server and due to the request-response nature of this protocol
> if the stream is interrupted in the middle of a sync no changes are finalized
> and the next sync will start again from the last available syncstate.

Excellent. So no problem as it is transactionnal.

> This said, I see on a previous bug report you filed that you are using a
> nightly build of CM9 for Samsung Galaxy S2. While I am a great fan of CM
> myself, remember that you are using a nightly build of a Custom ROM which is
> still in Alpha stage, and this does not help when analyzing device-side
> problems...

I knew that question will come :-)
CM9 is so far very stable as I carefully choose the releases.
The official Samsung ROM will be released on April 15th or so, then I'll check if the problem still occurs.
But, I doubt that Cyanogen team modified the Active Sync protocol implementation which should only be the original Google one.

> I double checked the sync management with the devs just to be sure and I'll
> leave this bug open to allow other people with similar problems to post this
> report...

Thanks a lot. That will give the time to compare with other ROMs or builds.

> ps: while the dynamic IP was not the problem in this case, I've seen different
> devices (mainly HTC and Samsung) which only perform the DNS resolution for an
> Exchange Active Sync account during the first sync and keep this data cached
> until reboot, and in your case such behaviour will prevent you to synchronize
> your account after a new IP lease until you reboot the phone..

Ok. This will prevent to synchronize, but what is responsible for the data wipe ?
Can this come from the phone also ?
Comment 7 D0s0n 2012-10-05 20:24:41 CEST
Release of ICS 4.0.4 resolve all sync issue.