Bug 39 - Calendar event delete on zimbra still present on mobile
Summary: Calendar event delete on zimbra still present on mobile
Status: RESOLVED FIXED
Alias: None
Product: ZeXtras
Classification: Unclassified
Component: ZxMobile (show other bugs)
Version: 1.2.5
Hardware: -- Linux
: Normal normal
Assignee: ZeXtras Bugzilla Admin
QA Contact:
URL:
Depends on:
Blocks:
 
Reported: 2012-04-11 14:51 CEST by Leroy
Modified: 2012-05-08 07:31 CEST (History)
3 users (show)

See Also:
Browser: ---
Zimlet Chat version: ---
Zimbra Version: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leroy 2012-04-11 14:51:48 CEST
I create task on on zimbra web mail
I see the task on my phone (Android 2.3)
I delete the task on zimbra web mail 
The task still present on my phone.
The task is delete on zimbra webmail(or calendar client with caldav).


I create task on on zimbra web mail
I see the task on my phone (Android 2.3)
I delete the task on my phone 
The task is deleted every where.
Comment 1 Leroy 2012-04-11 14:52:26 CEST
sync.log, they are nothing.
Comment 2 kral 2012-04-12 10:50:06 CEST
Hi Leroy,

this kind of issue was known and we have fix it on 1.2.5 version, as you can see from the last changelog here:

http://wiki.zextras.com/wiki/Changelog#Version_1.2.5

Our suggestion is to make an upgrade and retry.

Can you please tell me which app are you using on your Android?
Comment 3 Leroy 2012-04-12 12:05:44 CEST
I am allready with version 1.2.5

I use The standard calendar of Android, the synchronisation is made by Exchange Active sync
Comment 4 kral 2012-04-12 14:33:58 CEST
As far as I know, the default Android calendar application doesn't support
tasks, that's why I asked you which client you are using.

At this point, what do you mean with task? Do you mean tâches or just calendar
appointment?

Which is the device that are you using for the tests? Does it run a custom rom?

Anyway, the log file should be in /opt/zimbra/log/sync.log.
Comment 5 Leroy 2012-04-12 14:40:35 CEST
/opt/zimbra/log/sync.log is empty
for my exemple task= "rendez vous" .
I use Sony Xperia Arc LT18i with Android 2.3.4 .
Comment 6 Leroy 2012-04-12 14:57:00 CEST
exemple .
BEGIN:VEVENT
UID:5b8c5226-2b85-4a5a-b351-8434bbe95e54
SUMMARY:test 
DTSTART:20110923T120000Z
DTEND:20110923T123000Z
STATUS:CONFIRMED
CLASS:PUBLIC
X-MICROSOFT-CDO-INTENDEDSTATUS:BUSY
TRANSP:OPAQUE
LAST-MODIFIED:20110923T123031Z
DTSTAMP:20110923T123031Z
SEQUENCE:0
END:VEVENT


sorry don't read task but Event.
Comment 7 kral 2012-04-12 15:57:41 CEST
Ok, so it's a calendar event. 

I did a search on the web and I saw that the default email/calendar/contacts client on Sony Xperia Arc is Moxier Mail (I read it in this page, http://www.sonymobile.com/global-en/xperia/in-business/ under "Apps for your business").

I downloaded the moxier mail app and made some tests, but I can't reproduce the problem. I make a new event on zimbra web client and it shows up on my phone. When I delete it, the event is deleted on my phone too.

Regarding the sync.log file, please check the permissions allowing the user zimbra to write on it, so we can have some more inputs for resolving your problem.

Ty.
Comment 8 Leroy 2012-04-12 16:26:14 CEST
If you want, i can create for you a account on my server to make some test.

I remake test . i creat event on zimbra webmail , the event appear on my phone, i delete this event on zimbra webmail, the event is allways on my phone.
sync.log have no new line during this test.
Comment 9 kral 2012-04-12 16:48:12 CEST
Sure, a test account would help.
Could you please create one and send the informations to community@zextras.com so we can make some tests?

Could you please check the permission on /opt/zimbra/log/syc.log? It should look like this:

$ ls -l /opt/zimbra/log/sync.log
-rw-r----- 1 zimbra zimbra 1433466 Apr 12 16:47 /opt/zimbra/log/sync.log

Thanks.
Comment 10 Leroy 2012-04-12 16:59:55 CEST
-rw-r-----  1 zimbra zimbra 1669473 11 avril 14:34 sync.log

i have send you account detail.
Comment 11 kral 2012-04-13 09:42:47 CEST
Hi,

we didn't received any email from you at community@zextras.com yet.
Comment 12 Leroy 2012-04-13 09:51:44 CEST
just resend to you
Comment 13 kral 2012-04-13 16:46:44 CEST
I've not received a mail yet. I checked the logs of our mail server but I can't find any mail from you... Can you check your mail server too?
Comment 14 kral 2012-04-13 17:50:13 CEST
Ok, I received your mail now, I will give a try on the account tomorrow.
Thanks.
Comment 15 kral 2012-04-17 11:54:11 CEST
Hi Leroy,

I made some tests with the account you provided, but I wasn't able to reproduce the problem.

I used the same client of your phone, Moxier Mail (http://bit.ly/IWz8X6) and the default Android calendar client, but the error reported did not occurred.

Could you make a test with the account zextras@dl-ci.com?

Does the sync.log file still empty?
Comment 16 Leroy 2012-04-18 08:19:38 CEST
It works with moxier.
But with default calendar it dont works.
The default calendar use default Exchange Active Sync

for exemple : http://rigelt.blogspot.fr/2010/08/exchange-activesync-on-android-phones.html

and when i make syncro with moxier, my default calendar have more event because they dont delete event when i delete it from zimbra webmail allaways.

I will try to use only moxier mail to sync this day, but i think that is not a good way for me, if zextras can t work with default sync, why prefere zextras to other tool of sync with zimbra .
To my minds the soluce is not so far, because only the delete from webmail fail.
i make you feed back soon. but if you can try sync with only default sync of android and not moxier you will see the bug i think
Comment 17 Cine 2012-04-18 10:14:59 CEST
Hello Leroy

A little clarification: we tested both the default client and Moxier (as Moxier is the default app on your phone). Both use the Exchange Active Sync protocol to synchronize.
Unfortunately we couldn't reproduce the problem. 

By chance, are you running a custom ROM like CyanogenMod or MIUI?

Also, can you please try the following steps:
- Delete the account from the phone
- Remove the device from the "Registered Devices" list in the ZeXtras Administration Zimlet
- Create the account on the phone and sync.


Regards,
Cine
Comment 18 Leroy 2012-05-08 07:31:39 CEST
This bug stop with the new version 1.2.7
thank you all
you can close