Bug 56 - NullPointerException in mailboxd.log
Summary: NullPointerException in mailboxd.log
Status: RESOLVED INVALID
Alias: None
Product: ZeXtras
Classification: Unclassified
Component: ZxCore (show other bugs)
Version: 1.6.5
Hardware: -- Ubuntu 12 - 64 bit
: Normal normal
Assignee: ZeXtras Bugzilla Admin
QA Contact:
URL:
Depends on:
Blocks:
 
Reported: 2013-01-07 12:00 CET by Nicolas
Modified: 2013-01-07 13:37 CET (History)
1 user (show)

See Also:
Browser: ---
Zimlet Chat version: ---
Zimbra Version: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas 2013-01-07 12:00:17 CET
Hello,

I found this trace in the mailboxd.log :

2013-01-07 12:53:34,723 ERROR [ZeXtras Real Time Notifier Thread] [tid=65;] extensions - ZeXtras Real Time Notifier: Exception: java.lang.NullPointerException
        at com.zimbra.cs.mailbox.calendar.Invite.decodeMetadata ( Invite.java:660 )
        at com.zimbra.cs.redolog.op.CreateInvite.deserializeData ( CreateInvite.java:122 )
        at com.zimbra.cs.redolog.op.RedoableOp.deserialize ( RedoableOp.java:273 )
        at com.zimbra.cs.redolog.op.RedoableOp.deserializeOp ( RedoableOp.java:382 )
        at com.zextras.lib.ZERedologNotifier.readNextOp ( ZERedologNotifier.java:360 )
        at com.zextras.lib.ZERedologNotifier.run ( ZERedologNotifier.java:301 )


My ZCS version :

Release 8.0.2.GA.5569.UBUNTU12.64 UBUNTU12_64 FOSS edition.

Thanks
Regards
Comment 1 Nicolas 2013-01-07 12:02:04 CET
Addtionnaly, "Ubuntu 12" choice doesn't exist in your bugzilla...

Best Regards
Comment 2 ZeXtras Bugzilla Admin 2013-01-07 13:13:16 CET
Thanks for the feedback, the devs are checking the issue...

Also, added "Ubuntu 12 - 64 bit" to the "Platform" drop-down menu.
Comment 3 Cine 2013-01-07 13:37:30 CET
Hello Nicolas!

Our devs report that this is a Zimbra issue caused by an error in the RedoLog's parsing of a calendar item's metadata. Because of this, the Real Time Scanner is not able to save the item, but such item will be backupped during the next Smartscan/Fullscan.

A quick look at Zimbra's source code in Perforce shows that the bug has been fixed, so I think that the fix will be included in the next Zimbra release (obviously I can't guarantee on this).

Have a nice day,
Cine
the ZeXtras Team