Bug 68 - Users can't rename friend on list
Summary: Users can't rename friend on list
Status: RESOLVED WONTFIX
Alias: None
Product: ZeXtras
Classification: Unclassified
Component: ZxChat (show other bugs)
Version: 1.8.3
Hardware: -- Ubuntu 12 - 64 bit
: Normal normal
Assignee: ZeXtras Bugzilla Admin
QA Contact:
URL:
Depends on:
Blocks:
 
Reported: 2013-03-19 02:09 CET by Marcelo Matos
Modified: 2013-03-21 13:13 CET (History)
1 user (show)

See Also:
Browser: ---
Zimlet Chat version: 1.04
Zimbra Version: 8.0.3


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcelo Matos 2013-03-19 02:09:03 CET
When a user try rename a friend on list, the new name appear on list, but when the user make a login/logout in your zimbra account the name backs to the old name.
Comment 1 Marcelo Matos 2013-03-19 02:26:02 CET
Steps to Reproduce:

1. Login on zimbra e-mail account

2. Go to Buddy List Chat and try to rename a friend

3. Logout e-mail account 

4. Login again with same e-mail

5. Open the Buddy List, the friend renamed on step 2 appears with old name
Comment 2 Cine 2013-03-19 08:09:30 CET
Issue Reproduced, analysis is in progress.
Comment 3 Cine 2013-03-21 10:31:12 CET
Update: 
The developers report this behaviour as "Working as Intended".
It's a design choice made to cover the greatest number of cases possible -e.g. a mailbox renamed in order to be assigned to a new user - and is also required for XMPP compatibility (which will be added to ZeXtras Chat in the future).

Renamed accounts will be removed from the friendlist of a user upon login.
Comment 4 Marcelo Matos 2013-03-21 13:13:29 CET
OK. Thanks for feedback. I'll wait for the new version with new features zxchat