Bug 76 - Iphone (IOS 5.0.1) cannot sync some calendar events
Summary: Iphone (IOS 5.0.1) cannot sync some calendar events
Status: RESOLVED FIXED
Alias: None
Product: ZeXtras
Classification: Unclassified
Component: ZxMobile (show other bugs)
Version: 1.8.5
Hardware: -- CentOS 6 - 64bit
: Normal major
Assignee: ZeXtras Bugzilla Admin
QA Contact:
URL:
Depends on:
Blocks:
 
Reported: 2013-05-11 14:54 CEST by prod-info
Modified: 2013-05-14 10:16 CEST (History)
1 user (show)

See Also:
Browser: ---
Zimlet Chat version: ---
Zimbra Version: 7.2.3


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description prod-info 2013-05-11 14:54:58 CEST
Good Morning,

When I try to sync my calendar using Zxmobile, nothing happens:
here is the /opt/zimbra/sync.log:

2013-05-11 18:51:57,339 INFO  [btpool0-1989://zimbra.air-austral.com/Microsoft-Server-ActiveSync] [tid=5163;] sync - [192.168.2.2] ZxMobile device Apple-iPhone2C1/901.405 asking for server configuration
2013-05-11 18:51:57,524 INFO  [jshubert@air-austral.com Appl870128GM3NQ] [tid=5163;] sync - ZxMobile Handler: [192.168.2.2] ZxMobile Command FolderSync on account jshubert@air-austral.com from device iPhone/Appl870128GM3NQ
2013-05-11 18:51:58,114 INFO  [jshubert@air-austral.com Appl870128GM3NQ] [tid=5163;] sync - ZxMobile Handler: [192.168.2.2] ZxMobile Command Sync on account jshubert@air-austral.com from device iPhone/Appl870128GM3NQ
2013-05-11 18:51:58,114 INFO  [jshubert@air-austral.com Appl870128GM3NQ] [tid=5163;] sync - Sync[3918]: Sync on folder path: /Calendar
2013-05-11 18:51:58,222 INFO  [jshubert@air-austral.com Appl870128GM3NQ] [tid=5163;] sync - ZxMobile Handler: [192.168.2.2] ZxMobile Command Sync on account jshubert@air-austral.com from device iPhone/Appl870128GM3NQ
2013-05-11 18:51:58,222 INFO  [jshubert@air-austral.com Appl870128GM3NQ] [tid=5163;] sync - Sync[3919]: Sync on folder path: /Calendar
2013-05-11 18:51:58,222 INFO  [jshubert@air-austral.com Appl870128GM3NQ] [tid=5163;] sync - Sync[3919]: Getting items older(or newer) than 14 days for type: 11 on folder: /Calendar
2013-05-11 18:51:58,225 INFO  [jshubert@air-austral.com Appl870128GM3NQ] [tid=5163;] sync - Sync[3919]: Removed items: 0; Changed items: 0
2013-05-11 18:51:58,239 INFO  [jshubert@air-austral.com Appl870128GM3NQ] [tid=5163;] sync - Sync[3919]: Unable to send item 75599 (folder 10) account jshubert@air-austral.com: Unknown Exception
        at com.zextras.mobile.MailItemEncoder.encodeCalendar ( MailItemEncoder.java:1148 )
        at com.zextras.mobile.MailItemEncoder.encodeCalendar ( MailItemEncoder.java:805 )
        at com.zextras.mobile.MailItemEncoder.encodeMailItem ( MailItemEncoder.java:117 )
        at com.zextras.mobile.syncop.Sync.writeNewItems ( Sync.java:504 )
        at com.zextras.mobile.syncop.Sync.handleCollection ( Sync.java:931 )
        at com.zextras.mobile.syncop.Sync.doProcess ( Sync.java:299 )
        at com.zextras.mobile.ZEMobileHandler.managePost ( ZEMobileHandler.java:280 )
        at com.zextras.mobile.ZEActiveSyncBackend.handleActiveSyncRequest ( ZEActiveSyncBackend.java:58 )
        at com.zextras.mobile.ZEActiveSyncBackend.doPost ( ZEActiveSyncBackend.java:33 )
        at com.zimbra.cs.extension.ExtensionDispatcherServlet.service ( ExtensionDispatcherServlet.java:99 )
        at javax.servlet.http.HttpServlet.service ( HttpServlet.java:814 )
        at org.mortbay.jetty.servlet.ServletHolder.handle ( ServletHolder.java:511 )
        at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter ( ServletHandler.java:1166 )
        at com.zimbra.cs.servlet.SetHeaderFilter.doFilter ( SetHeaderFilter.java:79 )
        at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter ( ServletHandler.java:1157 )
        at org.mortbay.servlet.UserAgentFilter.doFilter ( UserAgentFilter.java:81 )
        at org.mortbay.servlet.GzipFilter.doFilter ( GzipFilter.java:132 )
        at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter ( ServletHandler.java:1157 )
        at com.zimbra.cs.servlet.ZimbraQoSFilter.doFilter ( ZimbraQoSFilter.java:114 )
        at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter ( ServletHandler.java:1157 )
        at org.mortbay.jetty.servlet.ServletHandler.handle ( ServletHandler.java:388 )
        at org.mortbay.jetty.security.SecurityHandler.handle ( SecurityHandler.java:218 )
        at org.mortbay.jetty.servlet.SessionHandler.handle ( SessionHandler.java:182 )
        at org.mortbay.jetty.handler.ContextHandler.handle ( ContextHandler.java:765 )
        at org.mortbay.jetty.webapp.WebAppContext.handle ( WebAppContext.java:422 )
        at org.mortbay.jetty.handler.ContextHandlerCollection.handle ( ContextHandlerCollection.java:230 )
        at org.mortbay.jetty.handler.HandlerCollection.handle ( HandlerCollection.java:114 )
        at org.mortbay.jetty.handler.HandlerWrapper.handle ( HandlerWrapper.java:152 )
        at org.mortbay.jetty.handler.rewrite.RewriteHandler.handle ( RewriteHandler.java:230 )
        at org.mortbay.jetty.handler.HandlerWrapper.handle ( HandlerWrapper.java:152 )
        at org.mortbay.jetty.handler.DebugHandler.handle ( DebugHandler.java:77 )
        at org.mortbay.jetty.handler.HandlerWrapper.handle ( HandlerWrapper.java:152 )
        at org.mortbay.jetty.Server.handle ( Server.java:326 )
        at org.mortbay.jetty.HttpConnection.handleRequest ( HttpConnection.java:585 )
        at org.mortbay.jetty.HttpConnection$RequestHandler.content ( HttpConnection.java:988 )
        at org.mortbay.jetty.HttpParser.parseNext ( HttpParser.java:756 )
        at org.mortbay.jetty.HttpParser.parseAvailable ( HttpParser.java:212 )
        at org.mortbay.jetty.HttpConnection.handle ( HttpConnection.java:415 )
        at org.mortbay.io.nio.SelectChannelEndPoint.run ( SelectChannelEndPoint.java:429 )
        at org.mortbay.thread.BoundedThreadPool$PoolThread.run ( BoundedThreadPool.java:451 )
Caused by: Invalid Recurrence
        at com.zextras.mobile.MailItemEncoder.addRecurrences ( MailItemEncoder.java:1299 )
        at com.zextras.mobile.MailItemEncoder.encodeCalendar ( MailItemEncoder.java:1129 )
        at com.zextras.mobile.MailItemEncoder.encodeCalendar ( MailItemEncoder.java:805 )
        at com.zextras.mobile.MailItemEncoder.encodeMailItem ( MailItemEncoder.java:117 )
        at com.zextras.mobile.syncop.Sync.writeNewItems ( Sync.java:504 )
        at com.zextras.mobile.syncop.Sync.handleCollection ( Sync.java:931 )
        at com.zextras.mobile.syncop.Sync.doProcess ( Sync.java:299 )
        at com.zextras.mobile.ZEMobileHandler.managePost ( ZEMobileHandler.java:280 )
        at com.zextras.mobile.ZEActiveSyncBackend.handleActiveSyncRequest ( ZEActiveSyncBackend.java:58 )
        at com.zextras.mobile.ZEActiveSyncBackend.doPost ( ZEActiveSyncBackend.java:33 )
        at com.zimbra.cs.extension.ExtensionDispatcherServlet.service ( ExtensionDispatcherServlet.java:99 )
        at javax.servlet.http.HttpServlet.service ( HttpServlet.java:814 )
        at org.mortbay.jetty.servlet.ServletHolder.handle ( ServletHolder.java:511 )
        at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter ( ServletHandler.java:1166 )
        at com.zimbra.cs.servlet.SetHeaderFilter.doFilter ( SetHeaderFilter.java:79 )
        at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter ( ServletHandler.java:1157 )
        at org.mortbay.servlet.UserAgentFilter.doFilter ( UserAgentFilter.java:81 )
        at org.mortbay.servlet.GzipFilter.doFilter ( GzipFilter.java:132 )
        at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter ( ServletHandler.java:1157 )
        at com.zimbra.cs.servlet.ZimbraQoSFilter.doFilter ( ZimbraQoSFilter.java:114 )
        at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter ( ServletHandler.java:1157 )
        at org.mortbay.jetty.servlet.ServletHandler.handle ( ServletHandler.java:388 )
        at org.mortbay.jetty.security.SecurityHandler.handle ( SecurityHandler.java:218 )
        at org.mortbay.jetty.servlet.SessionHandler.handle ( SessionHandler.java:182 )
        at org.mortbay.jetty.handler.ContextHandler.handle ( ContextHandler.java:765 )
        at org.mortbay.jetty.webapp.WebAppContext.handle ( WebAppContext.java:422 )
        at org.mortbay.jetty.handler.ContextHandlerCollection.handle ( ContextHandlerCollection.java:230 )
        at org.mortbay.jetty.handler.HandlerCollection.handle ( HandlerCollection.java:114 )
        at org.mortbay.jetty.handler.HandlerWrapper.handle ( HandlerWrapper.java:152 )
        at org.mortbay.jetty.handler.rewrite.RewriteHandler.handle ( RewriteHandler.java:230 )
        at org.mortbay.jetty.handler.HandlerWrapper.handle ( HandlerWrapper.java:152 )
        at org.mortbay.jetty.handler.DebugHandler.handle ( DebugHandler.java:77 )
        at org.mortbay.jetty.handler.HandlerWrapper.handle ( HandlerWrapper.java:152 )
        at org.mortbay.jetty.Server.handle ( Server.java:326 )
        at org.mortbay.jetty.HttpConnection.handleRequest ( HttpConnection.java:585 )
        at org.mortbay.jetty.HttpConnection$RequestHandler.content ( HttpConnection.java:988 )
        at org.mortbay.jetty.HttpParser.parseNext ( HttpParser.java:756 )
        at org.mortbay.jetty.HttpParser.parseAvailable ( HttpParser.java:212 )
        at org.mortbay.jetty.HttpConnection.handle ( HttpConnection.java:415 )
        at org.mortbay.io.nio.SelectChannelEndPoint.run ( SelectChannelEndPoint.java:429 )
        at org.mortbay.thread.BoundedThreadPool$PoolThread.run ( BoundedThreadPool.java:451 )

2013-05-11 18:51:58,244 INFO  [jshubert@air-austral.com Appl870128GM3NQ] [tid=5163;] sync - Sync[3919]: Added items: 26

The same sync Using Android 4.2.2 (Cyanogenmod 10.1) is working well.
Best Regards,

js.
Comment 1 Cine 2013-05-13 14:36:30 CEST
Hello js,

it looks like there is an issue with the #75599 item on that mailbox.

It would be of great help if you could send a copy of that item to community@zextras.com - to obtain it proceed as it follows:

- Log into the account through the Zimbra Web Client
- Open another tab on the same browser window you used to log in
- Enter the address of your server followed by "/service/home/~/?auth=co&id=75599&mime=text/plain&noAttach=1"

e.g.: https://mail.yourdomain.com/service/home/~/?auth=co&id=75599&mime=text/plain&noAttach=1


Also, are you sure that this very item is synced to the Android device? Can you see the item on the mobile?

Have a nice day,
Cine
Comment 2 prod-info 2013-05-13 19:21:31 CEST
Hello,

It don't seems to be sync on Android too.
I send you in private the item ;)
Best Regards,

js.
Thank you again for your help.
Comment 3 Cine 2013-05-14 10:16:48 CEST
Item received and analyzed:

the "recurrence rule" field of the ics file is not standard-compliant, thus was not correctly handled by some clients.

Starting from ZeXtras Suite 1.8.6, a workaround will be added in order to submit standard-compliant data even in this particular case.


Thank you for your report!